Trouble Download ELEMNT Maps

Is anyone else having trouble downloading maps and updates to their ELEMNT units? I have an original Bolt and am close to pulling my hair out trying to update some maps. It usually takes forever, then “FAILS”. I’ve talked with customer service twice and they have been no help, blaming it on my WiFi. I have no trouble downloading anything else. So why is it the WiFi’s fault now?

1 Like

I’ve had issues like this with my Roam but not as badly as it sounds for you. Firmware updates often start downloading then fail. Watching the progress percentage if it keeps stopping and starting then it will likely fail - successful downloads tend to count continuously up to 100% fairly quickly.

I only rarely update the maps but that has been equally if not more problematic than firmware updates.

I’ve always got there in the end - or in the case of firmware just abandoned and tried again a few days later and it’s worked so I’ve never really investigated it or raised a support ticket with the minions.

Frequently a slow/failing download will be immediately followed by a fast successful one. I have just assumed it’s a case of the Roam not doing a very good job of beffering slow downloads and/or the Wahoo download server being slow, I don’t belive it’s WiFi issues at my end.

I’ve had this with my Bolt a few times. It seems to be almost random as to whether it’ll work or not.

I had a similar problem with a few maps and deleting and re downloading them solved the problem for me.

I’ve had similar problems. The ELEMNT seems to need a bunch of free memory to do downloads—so I’ve always had to delete first.

I’ve also had this problem.

I found that turning the Bolt off and then restarting and redownloading the map results in much better speed and a better chance of completion. I once had to do that twice when downloading a very large map.

Same here. Last Saturday suddenly the map ‘disappeared’ from my screen after about 50km during a 180km ride and only the chevrons remained. I tried to delete all maps, reboot and then download all maps to the Bolt v1 couple of times. No positive result.

Eventually I have given the Bolt a factory reset and after that downloaded the maps again. Went almost seamlessly. The ‘almost’ was the map initially represented distance in feet, but after another reboot the distance was represented in (kilo)meters. Even though the metric settings in the companion app was set to ‘metric’.

Bolt FW version WB15-14984.

Same here, it is not wifi obviusly since it is syncing my strava routes while I am downloading the map. How could you explain that Strava is able to sync maps but not The roam app?

1 Like

@Antonio_Medina_Milti Log a ticket with support. Sometimes they push updates and something may have gone sideways with your install.

Downloading maps is super slow with my Bolt. What works though - and this is annoying and very boring - is to keep the companion app open and awake on your phone while it is downloading.

One thing I’ve found too (with my Roam) is that if I’m using ‘public’ wifi, say if I’m cycling abroad and trying to use the hotel’s guest wifi, that can be really unreliable. But weirdly, even though I can’t download maps through my own phone’s mobile data, if I hotspot my phone (and then my Roam) to another phone, the Roam recognised that as a wifi connection, and it works. Can be pig slow, but it gets there in the end.