Wahoo Elemnt Roam Update

I got an Element Roam for Christmas and when on the app, connected to the head unit, it says an update is available (see image). When I press this, nothing happens. I’ve tried it not plugged in, charging, at 50% charge and at full charge. I have then tried to go into settings via the device itself to ‘check for updates’. It says ‘waiting’ but does nothing beyond that.

Anyone know what’s up with that and how to run the update?

Is it set up to connect to wifi, and is able to successfully connect? Firmware updates and map updates download over the wifi the unit connects to.

1 Like

Yes it is connected to my wifi and it shows maps

It’s not very well explained, but usually if you leave it connected for a while it downloads, and then installs/restarts automatically. It’s erratic though - maybe depending on WiFi connection. Has been like that for me from the beginning.

My error. It would appear the Roam/App were not connected to my wifi and I have just read that:

“ELEMNT, BOLT, and ROAM only support 2.4GHz wireless networks”.

My network is 5Ghz. How do I therefore run updates if it won’t connect to my wifi?

I appear to have found a workaround for having a 5Ghz wifi at home… I put Personal Hotspot on my phone with Maximise Compatibility on which puts your hotspot at 2.4GHz. Connect the app to the hotspot to run the update.


Thanks for this suggestion. I’ve disabled my 2.4ghz wifi recently, and this helped without having to re-enable it.