Use Wahoo Systm workout in RGT

Hi is there anyway of importing a workout from Systm which has no video into RGT to complete it on a virtual climb?


Unfortunately not as of yet, unless you recreate it yourself in something like Training Peaks.

I did that several times using SYSTM on my mobile and RGT on the computer. Therefore I connect the trainer with Bluetooth to the phone and RGT is only connected as read only power and HR via ANT+.
Works pretty good.


I have a tool that converts workouts in the SYSTM calendar to FIT files that can be copied onto your headunit, and it seems the RGT workout import can support FIT files too.

Have just imported a bunch into my account, and it looks like it works fine, haven’t actually ridden yet to see though.

However, I don’t really want to publish the tool without permission from Wahoo…

@David.McQuillen.KoS thoughts?

1 Like

@jessicat That may work well for you but may not work for others since the exported workouts are likely based on your individual numbers.

Ideally the workout should be programmed based on % of FTP so that it adapts to each individual. I think the longer term plan is for RGT to both include NoVid workouts and also use 4DP numbers.

@Daviescgwen For now the workaround I use is to create the workouts in TrainingPeaks and then send the file to The same workouts can also be sent to my bike computer if I want to ride outside.

It fetches the rider profile, but a user could simply plug into a form; either way, the values are all correct according to 4DP.

I tried this yesterday using Bluetooth with RGT and ANT with Systm but with no luck.

This thread has your answers:

Getting SYSTM workouts into RGT

Other similar workarounds have been around for a while now and published on this forum, see my post above.

If it’s useful, I’d post it.
I believe Wahoo have plans to allow this to be automated between the systems in future, which will be great, but so long as you’re a subscriber exporting your exercise setup into another system in the same ecosystem, then I’m not sure there’s too much to find fault with, at least until we’re provided with an in-system function.

That’s unfortunate. Maybe it helps if I elaborate on my setup.
First, I open SYSTM on mobile and make sure it connects via BT to the trainer. SYSTM will then set the power in ERG mode for the trainer. Then I open RGT on the PC. In RGT I make sure to disconnect every sensor that’s there. When that’s done, I connect the HR sensor via ANT+ and the trainer as the power source. You really need to make sure the trainer is only connected as the power source and not as “Control.” Make sure to switch “Erg Mode” off in RGT. You can still connect it as a cadence source as well.
As soon as you start the workout in SYSTM RGT will read the power data and pace your Avatar accordingly.
I really hope you find this helpful.
One other thing I tried a lot but what never worked was to run both, SYSTM and RGT on one machine (PC) with different input devices (BT, ANT+). But that does not work.

1 Like

When I tried it I ran both on my mac. This didn’t work. I’ll try your method. Thanks

Okay, I published the tool, it’s pretty basic.

Your details are not stored anywhere, it’s just passed directly to SYSTM’s API.

For use in RGT, just attach the desired FIT files to an email to

I can’t guarantee uptime, it’s hosted on a really terrible home internet connection, but hopefully it’s useful.

1 Like

Depending on the trainer, if it has dual bluetooth like a lot of the KICKRs have, then you can use that for both connections and skip ANT+ (which I find suffers from more dropouts).

1 Like

Great hint @Devries. Since I use a first gen Tacx Neo, I was unaware of that. However, I have much more issues with BT than with ANT+. ANT+, to me, seems more reliable in terms of connection. But BT is superior in terms of data transfer speed. But I need to redo the connection process every time I use SYSTM because other than with ANT+, the app never remembers the connected devices (actually, it does remember and list the devices but never connects to them again unless I unpair and pair them again).
Anyway, when using the trainer as a read-only power device in RGT, all of that is no issue at all. Because the downsides of ANT+ only occur with the app controlling the trainer’s resistance.

One advantage of ANT+ is that it broadcasts data. That means any number of devices can pick up the same signal from a sensor. It could be one, two, a dozen… BT requires one-to-one pairing so only one device can pick up the data. If your trainer or sensor has dual BT channels, then only two can pick up the signal.

1 Like

Thank you, this worked well for me

Just tried running both SYSTM and RGT on a single Windows 10 based laptop (very powerful one).
Using your setup: ANT+ in RGT and BLE in SYSTM. It worked well, though I didn’t test it longer than for 2 mins (not mine usage scenario). You need to start ANT+ app first, ANT+ dongle can be used by one app exclusively only (in Windows).
Here how it went:

  1. Launch RGT, go to sensors, disable BLE. I’ve got Kickr’18, it reports itself twice, one is “fitnessequipment” with power/cadence/control, the second one is “powermeter” with power/cadence only. Connect “powermeter” sensors only.
  2. Start “just ride” workout, wait till it completes startup (when your avatar is ready to begin pedalling).
  3. Launch SYSTM. Start your workout. Kickr BLE connection starts in usual way with climb/power/power control/cadence/speed options (as of Kickr’18 + climb setup). I selected all except speed.
  4. Minimize SYSTM on top of RGT. Both started once I started pedalling. Both reported power & cadence (speed too, presumably, but I didn’t pay attention to it).

It worked flawlessly for 2mins, no freezes, etc. Yet fans in the laptop went crazy momentarily.

1 Like

Did you mean tried? Tired looks quite negative otherwise.

Thank you! Corrected.