BUG REPORT: Profiles and IF missing

So. Win 10. SYSTM. Cycling, sort by duration, results…have no IF and don’t show the workout profile. Shutdown SYSTM, restart. All good. But this has happened 3x now. Anyone else?

Even if you sort by IF on Windows 10 the IF does not appear in the list of workouts. The same is true of the iOS version on the phone.

:thinking: IF appears on my iPhone phone when I sort.

Short answer…YES. I have had similar issues since the last update a few days ago.

Curious. What version are you on? I’m on 7.13.1. It updated yesterday and works fine. I’ve tested it on Windows, Mac and iOS. The previous version only came available a few days ago (7.12) and may have broken something, but the 7.13.1 update available now fixes whatever the problem may have been

I’m on 7.13.1 also. And just to be clear, this bug is reproducible, but also inconsistent. If it happens and I close SYSTM and restart, the IF and workout profiles appear. This is also a recent thing - did not happen until 7-10 days ago.


Lo and behold, right now the IF appears on my phone.

…and as if on cue, I can’t–they’ve disappeared from my Windows machine. As @giorgitd said, the bug is inconsistent. A couple hours ago, the app worked fine on my PC.

Out of curiosity I started Systm on my windows machine. I saw exactly what you describe, no IF and no ride profile. About 30 secondss later the app told me there was an update. Installing and restarting appears at least to have fixed the problem.

Could be conincidental, could be the inconsistent bug, I dunno. Thought I’d mention it though.

Interesting. I just checked and was on 7.12. When I clicked on that, it said an update was available and now I am on 7.13.1. I thought they were pushing updates to Windows users. Apparently not.

After updating to 17.13.1 the app is slow to load and more often than not it does not populate fully. Ride profiles in the library do not load unless I close the app and reopen.

I also notice that for the first time videos will hang and the definition is compromised most of the time. I don’t download videos because I have a very solid and fast internet connection. Never had a problem with videos prior to updating to 17.13.1.

I run SYSTM on windows 11 (current) with a powerful GUI. I have no problems streaming/loading other apps such as Zwift (oops).

I’m waiting to see if the forum yields any information before pinging the minions.

1 Like

@brumohr Stuff to try: (1) log in and log out again and/or (2) delete and reinstall. Most of the time those two options solve the issue.

I have tried logging out and back in…no joy. Will try deleting and reinstalling, thanks.

I deleted 17.13.1 and downloaded SYSTM from the Wahoo Fitness webpage. Version 17.12 downloaded and I didn’t have a choice on version.

Ver 17.12 loaded briskly and fully on each of about 5 attempts. Ran a couple of workout videos without downloading and they played brilliantly with no definition degradation or hangups.

I was surprised that I didn’t get a prompt to update to 17.13.1 in the half hour I had the program running. I have Kitchen Sink (Mash-up) cued up for tomorrow so will have 3 hours to test. :crazy_face:

1 Like

Hi, I have had the same issue since the 17.13 update. I have not reinstalled yet as I assume I will lose my plans but will it not just update from 17.12 to 17.13 at some point introducing the same issue?

@ShaneA You shouldn’t lose anything - seems to all be in the cloud and it just downloads again after the reinstall. That is how it has worked for me on iOS.

1 Like

I submitted a ticket regarding my earlier post on 17.13.1. Minions told me that they rolled the version back to 17.12 so this is the version currently available for download which is what I am running now problem free.

I received no explanation for the roll back and didn’t ask.

Here are the instructions I received:

  • Windows 11: Start Settings from the Start menu.
  • Click " Apps ." …
  • In the pane on the left, click " Apps & features." …
  • In the Apps & features pane on the right, find the SYSTM app and click on it. Select uninstall .
  • Windows will uninstall the program, deleting all of its files and data.
  • Search and find the following files: C:\users\username\AppData\Roaming\SYSTM and C:\users\username\AppData\Local\SYSTM (Where \ username \ is the username you have for your computer, not the SYSTM app).
  • Delete these files
  • Reboot your computer
  • Reinstall the app using this link: [Download the App]

Download App)


If the issue is in the code, and not it’s interaction with a server, they will probably introduce 17.13.2 (or go straight to 17.14.1) so that the same issue are not re introduced, meaning that users on 17.12.1 never go to 17.13.1

I’m surprised they didn’t just take 7.12.1, re-version it as 17.14.1 and fix the issue by rolling everyone forward that way. Perhaps the Devs want to keep some people on 7.13 while they get a better handle on the issue?

I have 7.13.1 on two PCs and they are both running OK albeit with the IF and Profile issue happening intermittently.

1 Like

^^^ This. Aren’t there enough fiddly actions to take to get on the trainer without closing and reopening SYSTM? Wahoo needs to send the couchlandrian developers for The Cure. Like, um, now!