Can a ride be retrieved?

Just done across the mountains recovery ride and the video was on and off and eventually just went off halfway through the ride and I kept on getting prompts to turn off the video, which after annoying me for a while I eventually did. Then 3 minutes before the end of the ride the whole app switched off and I was back to my phones home screen. I went back into the app and the ride record was gone so I tried to get it again and all I got was a new ride to start again which I switched off and now there is no record of my original ride. Can this be retrieved by the powers to be? I know it is no big deal being only a recovery ride but I like to keep things as accurate a possible thanks.

Sometimes. You can contact SYSTM support minions and ask. They’ll help if they can.


I had this once on Android. The next day when I opened the app, that ride appeared and synced. (I had even done a ride in between)

1 Like

I contacted Systm support and was told to uninstall the app and reinstall to clear the data on the app??? did this but the workout never appeared. Anyway, the next workout was fine but I did two today (1hr and 13 mins and 53 mins) the second one went haywire after a short while, the video was stop and start and the countdown timer was erratic too. After a while the video seized and i had a message to turn off the video which I did and the workout continued on fine minus the video until 3 minutes from the end (really frustrating) where the app disconnected completely and I was back on my phone home screen again! This time I got a partial recovery (28 minutes) which must be about the time the video went off. Surely I don’t have to uninstall and reinstall the app every time I want to do a workout just to stop it crashing? anyone else had this problem? thanks

Are you downloading the workouts ahead of time? I wonder if you’re experiencing an unstable connection. But I really have no idea.

No, tried that and it took an eternity. I have been using them straight from the calendar however that works (streaming??) not techy so don’t know what you call it. They have worked fine up until recently

Try downloading one the night before. It sometimes takes a long time, but if you do it the day before, that won’t matter. Maybe that will help. If it doesn’t, it rules out a big potential cause.