Can't get Systm to work on new M1 Macbook Air

I have it running on my very old iMac but have set up my trainer with a new to me M1 Macbook Air. I downloaded and installed the software but when I open it all I get is a black screen without any controls. I get the menu bar. My M1 is a base model with a cracked screen that is attached to a 27" Dell UHD monitor. Everything else just works on it, including Zwift.

Any ideas out there?

There are different versions of the app for MacOS. You need the one for “Apple Silicon” for your M1:

1 Like

That’s the one I used. I suspect it has something to do with the fact that I use screen mirroring to use this computer since the laptop screen is cracked and unusable. The Dell monitor is attached using a USB-C 3.2 cable which carries the display, the power, and USB hub all on one cable. It makes for a much neater setup without all the cables.

I’ll try playing with resolution of the screen, and maybe try it over HDMI but since the HDMI just adds yet another layer of translation I can’t imagine it would be better. As I said, Zwift works in 4k resolution and it looks stunning.

1 Like

The newer Macs with Silicon will run some, but not all Intel software. Suspect that there’s something causing issues with the program. First thing I would check is that the Silicon version was downloaded.

I am definitely using the Apple Silicon version. I’ve downloaded it 3 times already. I’m suspecting it has something to do with the monitor setup, except the monitor needs to be there because of the cracked screen on the laptop. Everything else has worked so far.

Well, before I hit reply I decided to try using the Intel version and that works. It is slower to load but usually I start up before I get my shoes on so that doesn’t matter. I’ll use that until I get the Apple Silicon to work.

@zacster No idea if it will work but you might give this app a try:

as it says the program has this option:

Option to auto-disconnect built-in screen upon connecting an external display - requires Apple Silicon (note: Settings/Displays/Overview/Connection management settings…).*

I wonder if SYSTM has some sort of limitation that just assumes the laptop built-in screen is primary, and only shows there? Not sure if this “auto-disconnect” will help, but may be worth a try.

EDIT1: Note, I just noticed that particular feature is a paid “Pro” feature, however, you get full unlock for 14-day trial to see if it works or not. “A 14-day trial is also available to fully evaluate BetterDisplay Pro before purchase.”

I use SYSTM on my base M1 MacBook Air to the TV in my cave and it works. The one thing I get in general on Mac is that the apps sometimes snap to the wrong screen when you put them in full screen mode and then I need to use Mission Control to drag them around.

But just replying to say it definitely “should” work on the set up so keep persevering :slight_smile:

1 Like

How are you connecting to the TV? USB-C through a hub to HDMI?

I couldn’t get my MBA to connect to my monitor using HDMI when I tried today but it could’ve been the cable. I’d rather use the USB-C to USB-C with a USB 3.2 cable connection anyway as it provides power and video on a single cable, plus the built in USB hub. I’m already using up my ports since I plugged a keyboard in, my HRM charger, and the ANT+ dongle although even with all that I have a free USB-C/TB port on the laptop itself.

Yeah I’ve got an Anker mini hub that has Power Delivery and that has HDMI, power and my Ant+ stick plugged into it. So I just plug that one USB C cable into the MBA and it has power and the other connections ready to go.

I found something else to try. The monitor uses Freesync for better gaming, and my MBA was at Big Sur, a release that didn’t support it. Monterey and higher do so I’m upgrading it to Sonoma. We’ll see if this helps.


Ah that sounds worth a try!

1 Like

I finally was able to update to Monterey and it worked!


Excellent :slight_smile: