SYSTM app download package is corrupt

I’ve been trying to download the SYSTM app every other day for a week now. The package online is corrupt. New downloads will not install on my laptop. Mac OS link on this page: Wahoo X Subscription for Indoor Cycling Apps | Wahoo Fitness

Have you contacted support ?

R u sure it’s the correct MacOS app? There is one for Intel and one for Silicon.

That’s a good question. How can I tell?

1 Like

No, I hadn’t reached out to them yet. I’ll give that a shot, thanks.

On the link you provided. It identifies which is which.

Edit: but you need to check your Mac first. Click the Apple icon at the top then select “about this Mac”. That should do it. I think.

1 Like

Thanks! So, I just tried that and yeah, it’s still corrupt.

1 Like

Then def send in a support ticket to the minions. Something is off.

1 Like

Will do, thanks Sir Glen :slight_smile:

1 Like

Good luck. Check back in when you figure out what went wrong. Welcome to the forums by the way. TONS of useful info and helpful people.

1 Like

Welcome @Isaac_Reid !

Can you post a screenshot of the error message you’re getting?

Sure can, here you go.

Thanks. I just tried downloading and installing the Intel version, and it worked OK for me. Is your Mac Apple (M1) or Intel?

My only other suggestion is to make sure you’re getting a fresh download. Try deleting any existing downloads of the .dmg file, and re-downloading. This is just in case somehow the download process is not overwriting your existing file, and the existing one is corrupt for some reason.

1 Like

This is more likely caused by downloading the wrong platform version. Can you click on the Apple, About this Mac, and post what is shown on the Processor line? Intel Macs will have Intel in the line. I don’t know what is on the Silicon Mac (M1, M1X, M2) line but it will NOT include Intel.

I did try downloading and installing the M1 version on my Intel Mac. It gave me some warnings about unsupported architectures, but actually allowed the installation to proceed. As expected, I could not run the M1 version of the app. During this process, I never got the ‘SYSTM is damaged…’ message that @Isaac_Reid showed in the screenshot.

1 Like

Thanks. You got what I expected. I don’t know what is wrong with the download unless it is really corrupt. the .dmg file shouldn’t unpack if the download was incorrect. Time to read out to the Minions (support) to figure out what is happening.

Your screenshot looks as if you tried to start SYSTM directly from the DMG file instead of moving it to your applications folder first. This might cause the problem.

I did not ask to have Sufferfest updated and this morning I get this message:

I can’t uninstall Systm and can’t use it either. Fix the damn bugs before you dump this crap on us.

1 Like

Hey @Waters, it is not uncommon for Antivirus programs to conflict with program/app installations.

I’d suggest you contact the support minions for assistance so you can get yourself up and running rather than commenting on an indirectly related thread in the forums. You’re much more likely to get the help you need.

You can get the minions attention here:

AVG has identified this ‘virus’ in several legitimate programs. It’s way to aggressive and you can allow the program to run. It’s not Wahoo’s fault and there is very little they can do to fix this.