Workout History Not Syncing

Anyone else having issues seeing your SYSTM workout in the history in your wahoo app?

I saw some folks were having login issues that seem to have been resolved. There may have been.a server issue. Have you tried logging out and back into n?

Where did you do the workout? Was it a SYSTM workout? Did you do it outdoors or indoors? Which Wahoo app are you looking for it to show up in your history? The ELEMNT Companion app, the Wahoo Fitness App or the Wahoo SYSTM app?

Workout was done in the Wahoo Systm app indoor workout.
After finishing the workout, it synced correctly to Strava but it did not show up in the Wahoo Element app in the history section which is my repository for all outdoor, indoor (systm & RGT workouts

I also logged out of everything wahoo, deleted the apps, reinstalled and logged back in to the same issue.

I’m hoping it’s just a small hiccup.

1 Like

Do Your wahoo fitness and SYSTM apps have the same email address. If so you might need to get the minions to help you out:

If not, you’ll def need the minions help.

Sometimes syncing just takes a while but it should be showing up.

I do, it has always worked for me before, both SYSTM and RGT shows up. Just not todays ride for some reason.

1 Like

You’ll have to do it again only increase the intensity to 200% :joy:


I did two SYSTM workouts this morning. The first didn’t sync, but the second did. Unlike you, my workout did not sync to Strava. I submitted a support request to see if they could recover the information.

I had a similar issue yesterday, first ride synced fine, second one failed. Let support know in case it helped with finding bugs but figured that it was the universe telling me that following up Superflag immediately with Santos Festival of Cycling 4 was probably not one of my best ideas.

Will do! Thanks.

What’s a fair amount of time to wait for response on support request? It’s been about 20 hours and I haven’t even seen an acknowledgement of the request. I went ahead and marked it complete, but the ride lacks the activity data.

Submitted second request the next day. Still no response. Today’s workout failed to sync properly. It only recovered about 10% of the workout. Based on the lack of response, I figure it’s a waste of time to submit a third. Not sure what’s up with the lack of support.

I finally called support. Apparently there was an issue with my email provider not accepting the the reply to. my support request. Glad to report the phone call resolved the issue.

1 Like