Elemnt Companion cannot stay connected to Roam v2

Hi, I have the Elemnt Roam v2 and use the Companion app on iPhone to use the LiveTrack feature. This does not work currently because the phone and Elemnt will not stay connected when the app is not in use.

I have enabled background use and ‘always allow location’ in the app settings but each time I go back into the (already running) app, it has to search for and reconnect to the Elemnt.

The app also sends multiple LiveTrack emails with new links each time, when it is only supposed to send a single one at the start of the workout - the behaviour is like the app reconnects to the device each time I look at it, then sends a new email, even if the workout is already in progress.

This was not a problem on my previous Roam v1 but has always been a problem since upgrading.
To diagnose, I have reset the Elemnt, and uninstalled and reinstalled the app - but the problem persists.

Anyone here seen the same problem or have any advice please? I usually ride solo and LiveTrack allows my family to check my progress and location, which is not possible at the moment.

I have not had this problem and have actually found the R2 and Live Track has been working better over the last month and a bit.

Are you on the most current R2 firmware, most current companion app and the most recent iOS version?

1 Like

Thanks for replying. Yes, I checked the versions of all 3 are bang up to date.

Even though it feels like a phone/app issue, it started when I changed device. I do still have the v1 computer so I’ll reconnect that to the app and see if the problem stays or goes.

So I’m using the ROAM2 myself that’s why I commented.

I’m not sure if this is what you do or not but I don’t need to have the companion app open for Live Track to work. I open the R2, I wait for my sensors to all get connected, I get that little “beep” sound from the R2 indicating my phone is connected (still I don’t open the CA) and the little phone icon shows up at the top of the R2 settings screen. I then can go to my ride page on the R2, press start to start the ride and within less than a minute, an email gets sent from Wahoo with the Live Track link.

And, for the most part, that’s it. I keep my phone and R2 on but I never actually open the CA and it’s been working great.

I live in Canada if that makes any difference.

1 Like

OK, I tested with the previous device (Roam v1) and the issue is still there. Thinking this means the phone/app is to blame, I reset settings on the phone - still did not fix it.

I’ll try the ‘no app running’ method on my next ride, thanks for the tip.

Today. I got the notice sent about an hour and a half into a ride. This time, I started a route and ended the route but continued riding and that was when the email got sent. Not sure if this helps in your case or not but thought I’d let you know.

Thanks, that sounds like some of my experiences - an email gets sent when you interect with the app.
I tried a ride this weekend without starting the app - the result was that no email was sent at all!
I’ve got a call open with Wahoo support but they’re not answering me beyond an initial request for extra information. Hopefully they can find an answer soon as the live track is one of the reasons I bought the device.

1 Like

Fwiw, I just updated to the latest iOS today and the “no app running” thing doesn’t work for me now, at least at the moment. That said, as soon as I open the CA the LT email gets sent so it’s still working :man_shrugging:t3:

I have a slightly different problem. The application element closes itself after some time, so after training, in order to download the training to the application, you need to connect it again and again. I have an Android phone.

1 Like

Not quite sure what you’re meaning here. Do you mean after you’ve done a ride you need to reconnect to the app for it to “sync” so it shows up in your ride history?

If so, that’s not uncommon.

1 Like

Probably so, I just wanted the application to constantly keep in touch with the device.

1 Like

Yeh I hear you. I think it generally does a pretty good job of keeping connected in the background but it seems that isn’t everyone’s experience. Not sure if that’s a wahoo cloud issue, a geographic location issue or something else.

1 Like

Im having the exact same issues as @screendj. I also use iOS. The only difference is sometimes everything works just fine, but most of the time the companion app disconnects from Roam v2 (usually before I even get on the road) and sometimes during my ride I manually re-establish the connection. I Agree that this is very disappointing because the live track link feature was absolutely one of the primary features I was looking for before I chose a head unit; we obviously all need it to be reliable, otherwise it’s worthless.

1 Like

Hi screendj,
My situation is EXACTLY the same as yours. I also have a ROAM V2, and the only time live tracking works is when the iOS app is in the foreground and the screen is unlocked/on. Of course I have also enabled Background App Refresh and Location Always for the ELEMNT app.

When the iPhone display turns on, I typically find that the ELEMNT app is no longer in the foreground, and when I switch to the ELEMNT app I see “ELEMNT not connected” on the Workout page. After a few seconds, the app will reconnect to the ROAMV2 and tracking resumes updating for the remote person viewing (until again when the screen goes off or until another app is foreground).

So far Wahoo support keeps replying to me with those same Background App Refresh and Location Always requirements, and I keep telling them I have (re)checked those settings. I even tried removing the ELEMNT app and its data and then re-installing it, just in case it was an app/data corruption issue.

Have you made any progress on your end yet?

1 Like

Hi @ChuckPDX that does sound the same. After a chat with Apple support I went as far as restoring my phone using iTunes instead of just from an iCloud backup. He said there’s a difference as the iTunes method restores a clean OS image before adding your user data, which the iCloud backup version does not.
The result is that the Elemnt and app do communicate much better - I’ve had some successful live tracks since doing the restore. It’s not been perfect though, sometimes the live track link just shows a very short part of my route.
My best results are when I have the phone app open and linked when I start the ride on the Roam, and the same when I end the ride.
Hope that helps!

Hey @ChuckPDX, welcome to the forums!
Maybe you and @screendj and @pmkatz could try something that works for me. Depending on what you’ve done today, it might not work until tomorrow.

Step 1: do NOT open the companion app. If it is open, or was open today, force close it and begin Step 2 tomorrow.

Step 2: (make sure you have not opened, or opened then force closed the companion app today or this will NOT work). Power on your ROAM2, connect all your sensors as you normally would. Start your ride. You should find that Live Track sends the email very shortly after doing this.

For some reason, force closing the CA seems to “break” the Live Track process thus requiring the CA to be open in the background. But when the CA is open in the background LT seems to work only some of the time and can be interrupted by any number of signal/gps/connection/proximity issues. The “break” is somehow fixed when the time changes to the next day.

1 Like

@Glen.Coutts - thanks for the suggestion. I will try it on my next ride (and prep the day before! LOL). I will report back on the thread.

1 Like

I have the same problem with the iOS app.
I even uninstalled the app, disconnect the unit then reinstall everything and pair again.

The app goes to sleep in background, so live track or any other phone related function from the app cease to work.

I do get iPhone notifications in the unit but that’s it.
Anyone from wahoo looking into this?

1 Like

I tried this on Saturday but the live track email did not send while the app was closed. I then ended that ride, opened the companion app, and started a new ride. This time the email did send OK.

The tracking did not work throughout the ride though and only showed a short track from a 5 hour ride, and the app did not stay connected to the Roam.

It’s really frustrating as this feature worked on my previous device with this same phone, and I’ve not been able to pinpoint what the problem is!

Thanks for your efforts, much appreciated.

1 Like

It’s not just that the Companion App has to be closed, it has to not have been open at all, at any time during the day that you are riding (until you are finished your ride at least). If that was the case for you and it still failed to send the email, then I am perplexed.