Heart Rate Device Missing Error


Have Garmin unit on the bike and Wahoo Systm running at the same time. The connection to the Garmin unit is always ok. But this error appears on the screen, whenever the device is missing on the laptop. It’s not so much of disturbance but during watching “inspiration video”, it will opaque slight upper right of the screen. (please refer to the image attached)

Question 1 :
Is there any solutions for this?

Items used :

  1. Garmin Heart Rate Monitor
  2. MacBook Pro M1 Pro : Connected Via bluetooth to HRM & Wahoo KICKR.

Thank you!!!

I assume that the HRM is connected to the Garmin by Bluetooth. Is there another device grabbing the second BT channel on the HRM?
Could you use ANT to connect the HRM to the Garmin head unit?
I don’t know about the Garmin HR monitor, but the Polar H10 requires that you go into the app and turn on the two-channel BT option. I spent a couple days wondering why I couldn’t get two connections simultaneously to record in SYSTM on my phone while having an application on my computer control my trainer.

1 Like

I don’t know if this fixes your issue but when having issues with my garmin edge and wahoo connecting an HRM via BT problem was solved by first pairing wahoo systm and then only turning the edge on and pairing otherwise sometimes I indeed lost connection.

1 Like

Also, it seems like SYSTM has a more tenuous hold on bluetooth connections than other apps, at least in Windows. I used to fairly regularly lose connection with my single BT channel HR monitor after 30 minutes or an hour when I was using SYSTM, but never with Fulgaz or RGT or any other app I tried. That went away when I turned bluetooth off on my phone while on the trainer, so clearly an app on my phone was waiting to steal the connection to the HRM and SYSTM gave it the opportunity.

Try turning BT off on your phone and see if you can connect with SYSTM


To connect my Tacx to SYSTM with Bluetooth, I have to remove it, exit the app, start up the app again, and add the trainer back.

I never had to do this in the past, and the minions were of no real help in solving this problem. I have no problem connect my Tacx to other cycling apps or hardware.


hi @CraigM .
The Garmin unit is linked to the HRM via ANT+. I will keep trying for other solutions .
Thank you .

hi @JC2020 .
Thank you for your advice. I will try this. coming Saturday!

thank you !

Hi @CraigM

I have just migrated from Zwift. Never had this issue previously. It could be the Systm’s bug, hope it will be solved in the near updates. Anyway will try the suggestion from @JC2020 .

Thank you

HI @Heretic .

Thank you for sharing!

1 Like