Heart Rate on strava issue

Is this a known bug ? When I upload my training to strava, the heart rate is weird.
I did 2 trainings with Wahoo SYSTM and this is the same for both trainings.




1 Like

@MaxT Definitely looks odd - probably interference or something. Maybe put in a ticket with the minions.

1 Like

Have exactly the same issue with the new app. On the old one works fine. So is not an interference but something related to software…

1 Like

On SYSTM, heart rate looks fine. When it syncs with strava, the issue appears.
When I upload the fit file on strava and on Xert, there is an issue.
Everything seems fine when I upload the TCX file.
Some of my workout sync correctly, but the majority have issue.
I raised a ticket, let’s see …

I too have exactly this issue. When I “zoom in” using Analyse on Strava, it looks like it’s recorded two data points correctly, then one zero, and repeats that pattern over and over.
This first started happening to me about a week before the SF->System switch over…

It is not always happening, green = good data, red = 1/3 HR points is 0

Response from Wahoo, makes sense.


Thanks for forwarding their response. In my case it’s not paired with anything else, but I will remove Garmin Connect from my phone just in case and… hope.

1 Like

FWIW, I’ve never had problems with Garmin Connect on my phone being in the vicinity of my training setup


I have nothing other than my Forerunner 920XT paired to GC and I run SYSTM on a laptop, and I don’t usually double-record (i.e. both SYSTM and my watch tracking the workout).

I just had a response from Wahoo as follows (and kudos to them for the prompt, personalised and genuine reply):

So I’ve got a cheap ANT+ dongle on the way from eBay…

1 Like

It makes sense turning off BT on your device with Garmin connect. I’m going to try that next time.
But I’m not convinced this is a problem with Strava. I’ve also uploaded a couple of activities from Zwift and the HR data looks perfectly fine. (I have used the same setup - laptop(bluetooth) + Garming dual HR strap + Tacx flow smart).

Yeah it’s not an issue with Strava - it’s an issue with SYSTM and bluetooth sensors. It just shows up on Strava due to how the data is charted. See my post above where I quote a response from Wahoo. They say it’ll be fixed…

I spent $20 and got an ANT+ dongle off eBay. It’s annoying to have to do it, but it works.

Looks like they’ve fixed it now!

1 Like