Bluetooth heart rate not show values

Bluetooth heart rate shown in Wahoo system app as connected, but the heart rate on screen remain – (zero)!
I removed and connect it again but the problem still remains!

Dumb question maybe but is it connected AND selected (heart icon green)?

Yes is on the screen and shiws no numbers figures, just the lines –

Could be that that the strap / sensor isn’t picking up your heart beat. Have you tried wetting the strap before wearing?

Working perfect with the garmin element, by measuring the values

I did that also but still no values

I have continuous issues with HR strap/bluetooth connection on Android. It usually connects but at some point during the ride it decides it’s had enough and switches off. It’s not the strap or HRM itself as I can re-connect the strap and the lights flashs but will not connect again during the workout. Wahoo replaced the HRM and strap but still the same.

@Yiannis_Yiann I go through this with HRM straps and here is my list of stuff to try:

  • Check battery
  • Don’t use Duracell bitter batteries (child proof coating creates issues with the sensor)
  • Wash strap
  • Take strap off sensor and wipe dry sensor after each workout
  • Don’t connect two straps at the same time
  • AirPods seem to interfere so put the strap on 1st
  • Replacement straps on Amazon sometimes work better than OEM
  • Check that other apps or a watch or bike computer are not connecting

I will add if I think of anything else.


That means that SYSTM cannot read the data being sent by your HRM. Are you running ANY other applications/devices that may be ‘stealing’ your BlueTooth data? If you are running Garmin Connect, shut it down as it will attempt to connect first and stubbornly it will NOT release the device, even if you remove it. I recommend setting up Garmin Connect to not start on system startup and restart your computer. Fortunately, on my system (a Mac) Garmin Connect does not run unless I start it and I have no reason to run it as I use the web for all communications with Garmin.

1 Like

I had an issue last week where on my windows 10 PC my Wahoo TICKR HRM bluetooth dropped out after 5 to 10 minutes and could not be reconnected or it just displayed zeros for HR. I switched over to a Polar H9 and had no problems, but that’s not my favorite HRM because it devours batteries.

Yesterday I deleted and re-added my TICKR HRM bluetooth in SYSTM, and while I would swear that I had tried this before, this time it worked and stayed connected for 59 minutes of The Way Out. The only thing I can think of is that between my first try at removing/re-adding the sensor and last night when it worked my computer restarted several times for updates. Try deleting the sensor, completely shutting down all apps, restarting your device, then try to add the HR sensor.


Are you using the Garmin and SYSTM at the same time? Some HRMs can handle that. Some can only connect to one thing at a time.

If you’re good there, keep in mind that many HRMs are fickle and won’t see your heart beat if you’re not appropriately damp. I always run my hand under water then dampen the strap contacts and my chest under them right after I put it on. Sometimes it works if forget. Sometimes it doesn’t—although once I’m sweaty enough it kicks in.

I have been having HR issue on RGT app on Windows 11. SYSTM app on the other hand hasn’t missed a beat. Same hardware, on the same laptop, so go figure.

Twice now my HR would connect to RGT app via Bluetooth but the value would freeze once the race starts. :man_shrugging: Yet to properly troubleshoot but goes to show issue can be app specific.

As you see the heart rate is connected without shown measure figures!
Any other can help to resolve the problem?

This was happening to me a couple of weeks ago. Deleted the HR sensor then paired it again and things have worked fine since.

1 Like

I’ve been running into this lately. The key is to WET the strap throughly. I mean SOAK it. There is something strange going on with mine and EleteHRV is receiving no readings or really strange reading (13 to 200 BPM with HRV values of 100 or more). Resoaking the strap and making sure it feels ‘sticky’ brings back the ability to read correctly.

@Yiannis_Yiann i just connected my HRM to SYSTM, not the other Wahoo apps. It is possible that the Wahoo Fitness App is not allowing the connection in SYSTM.

I’m having the exact same problem as Yiannis_Yiann. 3 emails to Wahoo help desk over the last 2 weeks and no response. (They are usually quite speedy with replies.) Garmin duo HR strap is connect but not displaying any numbers. Have rebooted KICKR and phone multiple times; closed all other apps, forget pairing in other apps, only 1 connection at a time. I’m trying everything in the comments and have not found a solution. This happens in the SYSTM app, RGT, and Wahoo apps. It connects to my Garmin watch just fine, but I think that’s with ANT+. (I did disconnect pairing with my watch as well to make sure it wasn’t conflicting with another device.) I’m on an Android phone.

Unfortunetely, mine still not working, the problem remains!

I had the same issue. I had to buy a new phone to solve it. I know it’s a very expensive problem, but you will need to explore fixing why Bluetooth is not interperting data sent from the Garmin device. BTW, you should look at the Garmin site for solutions to Garmin equipment issues (this affected not only SYSTM but a Heart Rate Variability program). What made working on the issue harder is a have an older Wahoo TICKR, which is BTLE only, that displayed HR data.

Garmin is sending me a new unit. Fingers crossed a new one works. However, I think it’s the same P/N, so it may crap out again after a couple of months. Time will tell…