I have problems with my KICKR v6 connection in SYSTM (Windows version).

I could add KICKR as ANT+ device (I have an ANT+ dongle) or WiFi device (judging from the icon look
I’ve chosen the latter. KICKR’s controllable BT option was not present (power & speed only).
The problem is that KICKR WiFi device has no “service” icons (power, control, cadence, etc.), just plain white background when I start a workout. It comes to normal if I remove/add KICKR WiFi device again. It happens almost every time I start a new workout.
Moreover, I think that despite its icon, it is not a true WiFi connection:

  • KICKR’s blue led turns solid when connection is established.
  • “WiFi” KICKR device is dropped momentarily when I disable BT on my laptop.
  • Starting a workout when KICKR is powered off: “WiFi” KICKR device is in Connecting state when laptop’s BT is on. It stops Connecting as soon as I turn off BT.

KICKR’s WiFi is set up correctly, solid white led, router can see it, Wahoo app reports it ok, I can ping KICKR from my laptop using KICKR’s IP or name.

I have a support ticket opened, they are supportive but the information flow is slow due to different time zones. So I thought that someone here might have had similar problem and had found a solution and would kindly share it with me :smile: . The community here is very kind and supportive.

If anyone reading this has KICKR WiFi connection working in SYSTM, could you please check:

  • Does connection work when BT is disabled?
  • Are there both BT and WiFi KICKR devices available in the “Add device” list?
  • Is blue led blinking or is it solid during WiFi connection? (only if no dual recording using KICKR’s BT, etc.)

Thanks in advance :wink:

@macnuts I don’t believe there is a WiFi connection yet for the Kickr with SYSTM. WiFi is definitely available on RGT.

It should be with SYSTM, Windows version. It is on supported list.

RGT (Windows} does not find WiFi sensor either. RGT (Android) has no such problem though.
I’ve allowed incoming connections for RGT Windows App in Windows Firewall, all protocols all ports, no avail.

1 Like

So, reading the details on that page, you need to set up the Kickr WiFi connection in the Wahoo app first before using Systm

1 Like

Yes. Thank you. It has been done.
Kickr’s firmware is the latest available, Windows and apps up to date.

@macnuts Apologies - you are correct. I am on IPad so should have mentioned that.

@macnuts What I did for iPad was turn off BLE and started cycling in RGT. The WIFi trainer then appeared. I then turned BLE back on and connected my other sensors.

Thanks @JSampson but that didn’t do the trick in Windows.

I managed to restore WiFi in RGT (Windows). I had to disable VPN network driver. WiFi sensor appears in RGT even if BT is disabled on laptop.

That didn’t change how SYSTM behaves though, it works the same as I described in my first post.
Except that WiFi works. I did an ultimate test: I connected 3 SYSTM apps on three different mobiles. All BT. I tired then RGT but it refused, so BT limit has been reached. I then started SYSTM, I had to go through remove / add sensor (as CLIMB icon was the only one) and it worked. I’ve got 4 devices doing the same workout (3 mobile had control set to off).


i have exactly the same problem with my kickr bike v2 via wifi

1 Like

Yes, the same problem exactly.
There are no sensors for KICKRv6 WiFi device available in the first workout after SYSTM is started.
All sensors are back for any consecutive workout, till the SYSTM is exited. SYSTM WIndows version.

Please create a support request complaining about that. I created mine 2 days ago about this issue. It is #1574607. Please mention it in your request, they might move it up their backlog then.

1 Like

opened a ticket yesterday #1575185. i will update it with urs and the link to this thread

1 Like

Likewise, I updated mine with yours.

Try ( if it’s a dongle) unplugging the Bluetooth and then plugging it in back in again - that works. OR forget the Kickr and re- scan.
Hardly ideal but it’s a recognised problem :slightly_smiling_face:

It may be a recognized problem but it is not our case :wink:
No need to do anything except restating a workout within systm. This is current workaround.

1 Like

Ok that hasn’t worked for me :slight_smile:
You may also find that if you use RGT but use SYSTM first, DirCon will not connect and a PC restart is required.

the wahoo app ecosystem is a total mess, disappointed to say the least. systm app is blocking all other apps from connecting. i have bluetooth / ant / wifi, if i start systm app first they are blocked in all other apps.

and ur proposed fix is to get of my bike to unplug my bluetooth to make my wifi connection work :smiley: ???

1 Like

I’ve never used RGT after SYSTM yet.
I used both simultaneously, though.
No vids in SYSTM (mini mode) on top of RGT.
SYSTM using WiFi, RGT using BLE (power only).
Never had problems with that (except having to start SYSTM workout twice :laughing:).

if i use zwift + systm i have to start zwift first. thats okay if u know about it.

the new kickrs with wifi getting no connection to systm is a really annoying thing imho. u should think its the same company at least their products should work together.

1 Like

RGT unlike SYSTM does not rely on the Bluetooth being present :slight_smile: