No movement despite OK connection WAHOO FITNESS


I have been using WAHOO FITNESS for 1 year now. I’ve never had any problems connecting or using it.
I use a Wahoo Kickr V5.
I haven’t been able to have a “stable” training since 2 weeks.
Sometimes it works, sometimes it doesn’t.
I also tried, on ZWIFT, all the connection possibilities, Bluetooth, ANT+, Zwift Companion… but nothing worked.
I tried logging in with a phone as well, that didn’t work either.

In the home screen, my sensors are correctly connected.
For Bluetooth I am at the maximum of the signal, for ANT+ too and I am in FE-Cxxx protocol.

Strangely, this happened to me after receiving my new GARMIN 955 watch, and installing GARMIN EXPRESS on the PC.
I have since uninstalled Garmin Express and turned off my watch, but the problem is not solved.

When I start training on ZWIFT or WAHOO FITNESS, (in bluetooth, ANT+, Zwift Compagnion) I pedal, the resistance is zero. I’m at 90rpm but it says 20rpm. After 5 seconds, the resistance increases “strongly” I can no longer pedal. it displays 50watts, then 5 sec then I pedal and the resistance is zero.

I contacted the WAHOO hotline which gave me plenty of instructions to follow but nothing changed.

Looks like a calibration issue. But calibration “SPINDOWN” can’t be done with KICKR V5

Can you help me ?
Thanks a lot.


Garmin Connect is NOTORIOUS for ‘snatching’ connections and not letting go. After you de-installed the application did you restart your device? The program may be holding onto the connection even though you de-installed it.


Sorry you’re having problems, submit a ticket to the customer service team and they will be able to talk you through solutions: