Problems with the System App & Wahoo Rollr and Dual Sided power pedals

I use the System App. I have a Wahoo Rollr, Wahoo Dual sided power pedals, Wahoo TckrX, Wahoo Headwind.

I don’t know if my problems are with the App or the Equipment. When I start the App my Wahoo Devices do not show under my devices. If I try connecting a device, it finds the device then hangs on Getting Info and I cannot go forward to Pair. To resolve this problem I have to restart my iPad every time before using Wahoo System or it does not find my devices.

If I go straight to a training session, System appears to find the devices but the power and speed numbers will be all over the place.

Having restarted the iPad and getting the Wahoo devices connected I have to perform a recalibration every time. If I put the Bike in Auto-calibrate the power numbers change over the duration of the ride. I have a PowerTap hub connected to the PowerTap App on my phone at the same time my Wahoo devices are connected to my iPad. So I have a solid reference point.

Cadence is stable and correct regardless of the System app getting the cadence from the Pedals or the Rollr and match the cadence on the PowerTap Hub.

The System App spedd is all over the place. I checked my speed at different cadences and gear ratios against the speed reported by my PowerTap Hub and the Hub is reporting correct speeds per gear ratio/cadence. Speed as reported by the Rollr or Wahoo virtual Speed are always incorrect. With either Rollr or Virtual Speed randomly giving higher speed values. Sometimes the System App will start off reporting correct speeds but then that will change along with power over the course of the workout. How can you rely on the App to report correct distance traveled if the MPH is wrong. The app can’t be projecting faster speeds due to going down hill as I an always level or going up hill.

When in ERG mode in a middle gear allowing for a lot of increase or decrease of power/resistance, the System will either not increase the ERG/Resistance to hit the Power number or will it not lower the resistance to get to the lower power number.

I have asked for help from Wahoo and so far no solutions have been offered.

I have deleted the app and reinstalled a number of times but this does not fix the problems.

One of the reasons I purchased the Power Dual sided pedals is because I thought my old PowerTap Hub was finally giving up the ghosts. But I think the problems could be with the System App. Who know!

One more thing, how can you train properly with dual sided power pedals if none of the wahoo apps show dual sided power in real time? The System App doesn’t even report dual sided power after the fact and per Wahoo you cannot connect two apps at the same time.

Highly frustrating.

Anybody else having similar problems. Any suggestions warmly welcome.

I have the Rollr but not the power pedals.

Random thought… have you tried locking the Rollr to your hub? It’s in the Wahoo app

Other thought was have you tried RGT to see how it behaves there?

I haven’t paid much attention to speed

Thank you for the response. I don’t have a problem connecting the power devices. I do have to restart the iPad before every use of the System App for it to discover my previously connected devices.

I believe the lock to single Power meter is a setting if you have multiple bike and riders in the same room to make sure you have connected to the correct device.

The lock can also be used if you have multiple power meters… I made the assumption that your PowerTap hub was still on the bike and working as well as your new Power Pedals. That why i thought about the Lock option.

That being said… i’ve had my Rollr for a couple of months now and have used it with a couple of different bikes which have different power meters and had zero issues… I’m using my iphone mirrored to my Apple TV for SYSTM and then the RGT Apple TV app…