SUF to Outside world sharing upload broken?


Finished a session in Sufferfest and the workout is not uploaded anywhere - Strava, Training Peaks, Today’s Plan, not even e-mail.

Looking at the both SUF and Strava servers status, everything seems normal, no issues or outages.

This happened today on 3 different devices and 2 different accounts. The workouts show in Sufferfest app as completed with all the recorded data correct, it’s just not shared outside.

Neither automatic nor manual upload works, even after restart.

Any ideas?


Same. Joyride uploaded fine, cobbler is not going anywhere.

In the app, in the activities section, you can manually upload the workout.
Does it work this way?

Maybe, now that ToS has started, the servers are suffering alongside with us :joy:

1 Like

Doesn’t work automatically or manually for me…

Nope, neither automatic nor manual upload works, even after restart.

Same here. Upload to Strava seems to be broken. Tried then to upload manually through passport but without any luck. Tried un-connect Strava and reconnect again but still without any luck. Guess there is something broken.

Same here.

same here tried loads of times wont upload to garmin,strava, or email, edited the comments box and tried again, no joy glad im not the only one

Hi everyone, we are so sorry for the trouble with this. I think it’s a very well timed Couchlandrian plot to put a damper to the start of the Tour! (they seem unusually organized this year…). Not to worry, we are already looking into this!


good point could be the ToS causing it

Yep I’m in the same situation…again figured it was a TOS thing…

Couchlandrian’s undoubtedly through some dirty donuts in the servers!!

Same, tried everything.

Mine is up and running. Thank you (and I just uploaded this mornings activity and all is good!)

For what it’s worth. I always wait fir the workout to fully show up in the activities list and sometimes that takes a few minutes.

Then I swap out to the calendar.

Swap back to workout list and that usually triggers it.

If not, I shut the app down and start it again.

That’s because this happens with a lot of workout sharing.

Hopefully whatever the problem is now is resolved fast, but if you ever have this issue in future the above often works.

back working for me thanks

A couple of friends completed stages about 4 hours ago, and they just popped through to Strava now, so clearly a bit of a backlog somewhere due to the volume of Suffering!

Tried a manual upload again and uploaded right away on Strava and Training Peaks. Excellent communications from the Minions; I got the feeling they jumped on this issue right away. Not much more we can ask for really.

1 Like

Same here. Joyride uploaded fine, I’m still waiting for Cobbler 4 hours later. Not to worry, it’ll be sorted and there are worse things we could have to worry about.

And on that it’s uploaded to Strava! Great work minions! :joy: