Wifi help

Hey all. Spoke to the Minions. Few times to check things through and it appears I have an issue with my iPad and my wifi. To be fair I often turn off home wifi on my iPhone as I have a decent 4G signal and it’s quicker and more reliable.

So my set up is that I run Suff on an iPad 6th gen. I don’t have a wifi signal in my pain cave so I like to download the vids to run.

My wifi is sky max and runs very quick. We have no issues streaming 4K hdr films etc and often have kids running tablets and phones etc simultaneously. So the wifi overall had the speed.

But downloading Suff videos to my iPad or iPhone is painful. It’s very slow and doesn’t always work. By comparison I can download a video to my iPhone on 4G in about 5 minutes. (I have plenty of data no worries). But my iPad is wifi only and it can take 45 mins to download. Often failing during the process.

I’ve heard of different ghz (I think) from the wifi and was wondering if this ought be the case or something I could try. So question. Anyone an expert in this that could advise.

Reminder nivea been through the minions on this and as I can stream on 4G no problems. And download on 4G no problems in the same device. It appears there is some issue with my wifi connection

Thanks in advance

1 Like

Sounds like you’ve covered most of the bases to be honest.

If you can download ok on that device when using 4G that rules out space limitations on the device (if it was nearly full it could be struggling to save the data …)

On VirginMedia it’s possible to configure the router so that different 2.4Ghz and 5ghz channels exist so you can prob do that on your router as well.

I’m not convinced that’s going to help given what you’ve gone through.

Do you have any other services such as Netflix or BT iPlayer or such like that have download options - so rather than stream them can you download a movie or something to test that?

Hey thanks. Yes Netflix. Disney + etc.
Tend to work fine. So there is something about the Suff app and my wifi.

It’s a bit of a first world problem to be fair but wondered if any tech gurus could help. I’d heard of the 2.4 v 5 thing but don’t really have a clue what to do or how to change things on that

I very much doubt changing the router Wifi frequency would make any difference in this case. I would imagine it’s something odd about SUF itself. I’ve noticed that it can sometimes be very slow to download videos on my iMac via Wifi (5 GHz channel). Other times it downloads at normal speed. I put it down to the SUF server load. But never really given it much thought.

Ok - can we do a wee test if yu happen to be online just now?

Can you go download Balance and Agility I … it’s only a 14 min toga video so would be good to see if we cwan compare

When you download a SUF video you’re actually downloading a lot of small files (~275 files in total for the short 225MB vid Martin suggested testing). The mobile provider networks are way better at efficiently handling this kind of thing than the OpenReach network (which is what your Sky broadband uses) so a decent 4G connection is likely to always beat a decent wired connection. That doesn’t explain exceptional slowness though (SUF’s UK server is about two miles from my house and while my download speeds are hardly blazing they’re not usually 45min). I doubt it’s actually WiFi related and using 5GHz instead of 2.4GHz is unlikely to make a difference. That said, can’t think of much to suggest…

  • Are you using a VPN on the iThings? If so, don’t.
  • Are you using normal or reliable download mode in the App? Try the other (reliable will likely be slower, 1min30 v 40sec for Martin’s testcase for me, but should be more, well, reliable if left to do its thing)
  • Want to extend WiFi to your pain cave so you can stream? Lots of cheap plug in thingies that can do that for you (WiFi extenders, PowerLine etc)

I used an iPad over the summer and encountered a similar issue. 4G downloads were fast while the Wifi downloads could take forever and even stop completely.

I never managed to get to the source of the problem. No device or app update could fix it. There were good and bad days. Sometimes it works, sometimes it didn’t. Since I switched to a Laptop I never experienced this phenomenon again.

Sorry I can’t post any productive tips.

Do you have a chance to try out the Mac or Windows App and see if the problem persists? I understand it’s no solution, but it would pinpoint the iOS devices to be the culprint in this scenario.

Sorry wasn’t on line.

It took me 55 mins to download ISLTA yesterday. I accept it’s a 2.5 hour video therefore a big file.

I think maybe that’s an issue.

I forgot to mention it’s a work iPad. So yes it runs through a VPN and other such security software. (One of the annoying things is it autolocks every 2 mins and I can’t switch that off, and it feels like when it’s locked it’s hit and miss whether it continues to download)

Ah well I’m changing jobs soon so will need a new device.

Thanks for your help folks.

1 Like

For what its worth and is probably related to your WiFi issues. I have had continuing issues with using my WiFi HomePod speaker and the SuffApp. Audio costs in and out and the video glitches at the same time. I have reported this to the Minions and they are aware but said there is no fix at this time. It is frustrating because I do not have this issue with any of the other apps I use for audio. Thoughts?

My wifi issues are mainly that my pain cave is in my garage and the signal just doesn’t carry through a couple of solid walls into the garage. Ive tried extenders etc but nothing is that reliable. (To the point I have network cabled up a couple of key points in the house, smart TVs and Sonos beam etc).

I don’t find it a problem as I can download the vids, and don’t use other online only platforms.

1 Like

I’ve had similar issues (today’s blender the vid just never really got going). Id been watching Netflix moments before, all good. I did a speedtest, all good). Finally decided that I’d need to learn how to download in advance, cos 1hr40 with no void trekked on mental resilience…


Is the problem also there if you use the iPhone as a 4G hotspot for the iPad?

If it isn’t there then I don’t know what it could be other than that the security policy/VPN/security client on the iPad does something different & funky when on VPN over Wifi or VPN over 4G.

If the problem is specific to the iPad no matter what kind of connectivity it has then I would think that the VPN client on the iPad only uses its Internet connection to set up the tunnel with the corporate VPN endpoint and everything is downloaded over the Internet connection that is connected to the corporate endpoint rather than your home WiFi (also known as split tunneling).

I download all workouts 1st, just don’t need the hassle of streaming issues. However this still does not fix the issue if trying to use any speaker that works on airplay.

Had the same. Downloaded vid, MacBook Pro and a pair of HomePod minis as a stereo pair. Vid and sound meh. Close to the Wi-Fi hub. Monterey and HP on 15.2

You can do a basic Speedtest to know where you are at. For example: https://www.speedtest.net/
For me the download rate from SYSTM exceeds my poor 80 MBit/s internet connection so no worries there.

With Wifi 5Ghz is preferable if you have a direct line of sight or no thick walls. But since you are going through multiple walls you should probably use 2,4Hhz. It’s best to select a free channel in the 2,4Ghz Band - 1, 6 or 11. But most Access Points do that automatically nowadays. Probably in the app store is a free Wifi Analyzer App which can list all Access points from the vicinity with their signal strength and you should use the best free spot.