Workouts don't save

Hi dear Sufferlandrians (and other readers :wink: ),

recently I have experienced multiple times the executed workout not saving properly. Or actually, not saving at all. The Minions are already on it but haven’t come up with a (working) solution (yet). Maybe some of you have experienced the same and can help us out or point us in the right direction. I am running SYSTM on a W10 laptop.

The story is as follows. On November 13th I did the ‘Four shorts by Joey’ workout. After the workout I clicked the ‘Save’ button but nothing happened. Tried to log out & in again, checked internet connectivity etc. but nothing. I assumed this would only happen once or so in a while.

Now the same thing happened to me twice in a row this week. First with the ‘The Way Out’ workout, then with the ‘Inside: Women’s Movistar Team - 2021 Vuelta a Burgos’ workout. The first workout was with the 7.13.1 version of the app. After consulting the Minions they advised me to completely delete the app (including all folders etc.) and reinstall again. Now I am running the 7.12.0 version and did the ‘Movistar’ workout with that.

Could it be something with my laptop? Anyone experienced the same? I did not have the same issues during the year I had Sufferfest (prior to SYSTM).

I’ve found that if you have only little space left on the hard disc, Sufferfest/SYSTM struggles to save workouts. Happened to me twice.

1 Like

You’ve probably been through this with the minions, but does your computer and software conform to SYSTM minimum system requirements?

From the website:


  • Windows 10 v 1903 or later (64 bit only)
  • Intel Core2 Duo or 1.3GHZ processor
  • 4GB of Memory
  • Tablet devices: The app will work on most Windows tablets, including Surface, except for those running Windows RT.
  • Hard Drive Space: 130MB. Downloaded videos will require additional space of approximately 1GB per hour of footage. Videos must be stored on the main drive.
  • ANT+ adapter if using ANT+ sensors.

Windows 10S / RT, Chrome OS / Chromebooks, and ARM CPUs are NOT supported.

1 Like

I haven’t had it happen with a ride, but I’ve had it happen 3-4 times with strength or yoga workouts in the last month. Basically the video gets to the end, and instead of finishing and bringing up the menu where you chose to save, it’ll just restart playing from the beginning again. And often there will be no controls to exit fullscreen or cancel/finish the video after it restarts, leaving the only option to hard stop the process.

This is happening on an extremely powerful gaming HTPC, so system requirements are not a concern.

@Skibikehike @marrekie This sounds like a a known issue and might have popped up again with one of the recent releases. Copying @gpsjared so that it is on his radar.

For these types of things try: (1) logging in and out of SYSTM and (2) delete and reinstall SYSTM. Otherwise keep reporting to the minions so that they can track and hopefully fix it.

1 Like

This happened to me yesterday with unplanned yoga. I did the workout, added a funny comment and it went to the calendar view. I was in a rush so assumed it had saved. Left the laptop open, but didn’t see it on strava so went to look for it later when I had more time but it wasn’t even on the calendar anymore. Did I imagine it? Sounds like I didn’t. My planned ride this morning did save though. whew. Still - something fishy. This is on a macbook pro.

@tpodowd I have stopped adding comments until after the save. It could be my imagination but that seemed to address it for me.

I am running W10 Enterprise (64-bit), version 20H2, OS build 19042.1415. Intel(R) Core™ i5-5300U CPU @ 2.30GHz. 8,00 GB (7,88 GB usable) RAM.

Sufficient HD space for the moment (27GB) and using ANT+.

The Minions now advised me to run the Windows Compatibility Checker:

  • right click on the SYSTM icon on your desktop
  • click on “properties” from the drop down menu
  • click on the “compatibility” tab and then click on the “run compatibility troubleshooter” button
  • once the compatibility troubleshooter is finished, click on the ​"try recommended settings" option

I have scheduled another workout for tomorrow. I will know the outcome then.

I have tried both. Without success. I will keep in touch with the Minions. They let me run a windows compatibility troubleshooter. I have scheduled another workout for tomorrow. I will know the outcome then.

This happened to me for the first time today on iOS. Both a cycling workout and a yoga workout didn’t save.

Same problem yesterday with iOS. ‘Lost’ all but 8 minutes of ventoux pro ride.