Xplova noza

Hey Sufferfest people,

bought myself an xplova noza s trainer and can connect it to android&ios.
when starting a systm video it does not show any wattage? Systm does find the trainer with bluetooth but does not react to it? :frowning:

other 3th party software works but not Sufferfest,
any other xplova people in here ?

Welcome to our forum.

I’m not familiar with the brand, but suggest a few steps that might (or might not) help. If you’ve done all of this already, I’d send a ticket to customer support.

  1. Make sure nothing else is connected to the trainer. It should t be connected to your phone, tablet, or anything else.

  2. Start up SYSTM and go to the device tab in settings. Sounds like you’ve been there. Do you see you device listed? If you do, make sure the little icons that represent different sensor channels are green. If they’re gray, click them and they should switch to green. The screenshot below shows what green icons look like. (One is gray—the speed sensor—because I selected, as you should, the SYSTM speed sensor that you can’t see in my screenshot.) The lightning bolt with a circle and the plain lightning bolt are the most important. The one with a circle is the channel that controls your trainer in ERG mode (and makes it a smart trainer). The one without reads your power.

  3. If you don’t see your device listed (or it’s listed in a window to the side), you need to add it. Click Add Device then click the trainer in the window that pops up. Close the extra window and go to step 2.

Hope something in there helps. If not, good luck.

akapete thank you for replying to my threat, this is what the app is giving me

android or ios it’s the same result

Have you tried contacting the Minions directly?
You might get an answer there faster.
It’s a small brand device which hasn’t had support added in other apps either, it’s entirely possible yours is the first to touch Sufferfest/SYSTM and communicates in fun ways.

As for things you can do for yourself, do you have an ANT+ dongle you can try? You might find it behaves better over that.

Open a support ticket here if you haven’t already

I agree with Sir @Jon — contact customer support.

In the meantime, it looks like SYSTM can control the trainer in ERG mode, but can’t receive anything back. If you try riding a workout, what happens? Does the power target and your required effort actually change even though you can’t see your power? Maybe you can workout, but I expect that it won’t record correctly.

I hope the minions in customer support can help you.

Did you have any success after contacting the minions?

I took a risk and bought one of these at the reduced price of £369. My Nova S arrived yesterday, assembly was easy. Connected to it to my iPhone via the Nova Workout+ app, because one of the kids was using the iPad that I use to stream workouts with the SYSTM app. When I went out to the garage later in the day to do a workout using the iPad the trainer would not connect to the iPad even if I turned bluetooth on the phone off. Couldn’t disconnect the bluetooth between trainer and phone via phone settings as it didn’t have the little “i” in the connections list. Eventually found that the only way to break the connection was to delete the app off my phone. When I finally got the trainer connected it was only showing the erg mode icon.

Did the workout anyway and the resistance changed in the right places but no power or speed recorded. Not impressed so far.

Just submitted a helpdesk ticket to the minions and a warranty claim to Chain Reaction Cycles

Bought the Noza for my wife to try out (she wanted just a cheap direct drive to play with and Costco was selling them so easy to return). Getting it to work with Zwift for her took some meddling and the power ratings on it were all over the place. We eventually set it to controllable and used her Favero power pedals for the power ratings. It worked way better. After we finally got it set up it seems ok but the ease of use is nothing compared to my Kickr. Hope they figure it out for you as it would be fun to get her on Systm and dying beside me during the nine hammers

Mine connected to Zwift first time. So it turns out its not a hardware problem, just a problem interfacing between the trainers firmware and SYSTM.

I got a quick reply from one of the minions as always :slightly_smiling_face: "We do have this identified as a bug and our development team is working on fixing it - but I don’t know when we will have a fix for the issue. I’m so very sorry! "

I’m still waiting on feedback from ChainReaction cycles who passed my claim onto Xplova…

+1 for fixing this. I have the Noza S too and get exactly the same when I hook it up to the app. I’m speaking to customer service but getting nowhere

i’ve bought an ant+ stick for my PC and connected the trainer to it,
that does the trick.