Activities won't sync to other apps

I’m really struggling to get my activities from Wahoo to Strava / Garmin / MyFitness Pal.
I’ve de authorized and re authorized, I’ve deleted and re installed apps, I’ve made sure the permissions are all correct and finally, deleted the caches.
Hopefully someone can help please.

1 Like

Hey @danny2156 and welcome to the forums. That can be pretty frustrating for sure.

Sometimes there’s a delay in syncing to the wahoo cloud depending on the activity and what you’ve recorded it on and/or your settings.

What are you using to record your activity (eg is it a cycling activity using a wahoo head unit or watch?, is it a workout you did using SYSTM or RGT, and if so what were you using to record?

Also, are you able to see the activity on the Wahoo Fitness App, the SYSTM app under the progress tab, the Wahoo ELEMNT Companion app, or the SYSTM web app?

Hi, thanks for the reply. I have just got a Wahoo Kicker and use the System app to do workouts and record my activity, which it does no problem. It actually worked yesterday and uploaded to Strava, but today, even 4 hours after the activity, it’s still not there.


What are you using the SYSTM app on (iPhone, android, PC, Mac) and are you able to see the workout you did today in SYSTM when you go to the progress tab?

Edit: also, fwiw, I find if something worked fine yesterday and doesn’t work today, more often than not, there’s a glitch in the matrix and it usually gets sorted in a day or so. Sometimes the issue is with Strava, sometimes with the wahoo cloud sync but if you haven’t changed any settings, in my experience, these things get resolved without any action on my part though it’s good to let The Company know.

Yup I got exactly the same problem this evening. This morning’s activity synced normally and this evening’s ones didn’t sync. The normally highlighted Strava icon at the finish workout was not highlighted.


Something that is interesting is that my Wahoo session didn’t have all the details today either. This started yesterday as well.


Hi, using an Android ohone and the workout is in the progress report…
Just used to my Garmin watch and Strava linking straight away after workouts, hate glitches and waiting - 1st world problem I know😀

1 Like

Same here, last night the Strava icon wasn’t highlighted, wouldn’t sync until I reconnected. This morning got a message when opening app to reconnect my Strava. It works but doesn’t show any SYSTM details like name of workout or pictures. It also didn’t record it as a Virtual ride


Yes got the same this morning, just a bland morning ride and morning weight training, no image, no proper title in fact nothing worth looking at. What the hell is going on with SYSTM, this is useless and gives no idea of what session it was etc, just a ride!!. Not sure what is happening with WAHOO but they need to get their act together or is this just another cost cutting exercise. Why change what worked for years? Another issue that may put people off this platform. Zwift manage it ok and with lots more info on the front page. Maybe someone at Wahoo, whoever is left, may like to comment on this fiasco!!


@ozmadman I saw elsewhere that this might be a Strava issue. Unfortunately software doesn’t stay static so stuff breaks from time to time especially when you get an operating system update.


Just to repeat, this is what I’m seeing. Activities go up, but no pictures, or descriptions or anything, just the default “lunch ride” or whatever. All the metrics are present and correct though.

EDIT: I seem to recall back when SF implemented this (uploading images), that they need “special permissions” from Strava as a “partner” or similar to do it (the facility doesn’t exist in the standard developer API). Could be that they decided Wahoo need to pay for it or something (maybe Strava subscribers only? I’m not so wouldn’t know), though I notice the Z-Word app still seems to do it.


I am not a paid subscriber either so would any of the above clarify whether their uploads to Strava today are still fine

I’m a strava subscriber. I had to reconnect my Strava account in SYSTM yesterday. Since then I get the same bland “morning ride” or “lunch yoga” as described above. No pictures or description of the activity


I suspect that being a paying Strava partner (for it does cost I suspect) has gone out the window for cost reasons.

Doesn’t really matter to me, 2 minutes to update it myself.

Even manually updating it yields the same lack of info

If that is the case why doesn’t Wahoo just tell us instead of us grovelling around in the dark and finding out by accident. The more I look into what’s going on with Wahoo the less likely I am to renew. I have already been looking into Zwift but Wahoo is the only training platform I have used and I don’t really want to change but RGT is a mess, the Platform is confusing with no instructions, you have to search round yourself to find out how things work, it keeps crashing, the roads are boring so its no wonder Zwift has the upper hand in that domain. Plus I am still not convinced that its not going down the pan despite all the talk of new stuff/rides etc.

1 Like

I guess they didn’t really want to shout from the rooftops about cost cutting measures :grin:

The whole virtual cycling/racing thing doesn’t really appeal to me - stat. No argument that the Z-app has better looks I guess. RGT seemed more realistic physics but Z-app has changed a bit since I last used it so maybe its more equivalent now. The only thing I found worthwhile on RGT was the Wednesday night omnium races (the exception to my rule!) but I wouldn’t miss RGT if it went. As a training platform Sufferfest was what I originally signed up for and as long as that part essentially keeps going I think it’s worth it for me, personally speaking.


Ok, got it working again. For some reason, Strava had deauthorised itself in the Systm app. Reathorising manually fixed it. Edit: just syncing, but still missing the images and description.


My latest update had a message to re-authorise. Suspect that the enhanced uploads were to a “paying partners only” api which they are no longer part of, thus everyone needed a new authentication key to go back to the “normal” public API.

You CAN change the activity title in the public API though and set other parameters, so why that part doesn’t work is a bit of a mystery. Perhaps they just haven’t got the public API side in the app back up to speed yet :man_shrugging:

So, I ran into the ‘generic ride’ upload issue last night as well with Strava after SYSTM told me I needed to reauthenticate with Strava.
Today I deauthorized the link from both sides again and then tried linking them up again and here’s what I noticed.

  • In Strava, under Apps, after authorizing SYSTM, it shows up as ‘Wahoo Fitness’. Previously I had it listed as ‘Wahoo SYSTM’.
  • Partner integration in Strava still refers to ‘Wahoo SYSTM’.
  • I suspect the ‘integration’ is not working because the new linking between apps is now under the name of ‘Wahoo Fitness’ and not ‘Wahoo SYSTM’.

That said, I’ve now ran into another issue. As last night’s rides were uploaded as ‘Evening Ride’, I deleted the rides in Strava and tried to re-upload/re-share from SYSTM, but now that’s not working… So I think I’ll need to manually upload the FIT files for my 2 rides last night :sweat_smile: