Elemnt roam V1 display problem

While on turbo training my speed and distance diplay switched to values approx. 1/3 the correct value i.e. 15.01mph to 5.6mph and has been such ever since. I have performed a direct comparison with my garmin explore and the sensor is working perfectly. I hve rebooted, changed sesor battery, performed a factory reset, repaired the sensor and sternly shouted at it and nothing has worked, have tried wahoo help line and found it usless. Can anyone help?
I compared speeds 10mph 15mph and 20mph all the same ratio.

The wheel sensor measures wheel rpm not speed, the head unit uses rpm in conjunction with a wheel circumference to calculate speed.

Have you checked the wheel circumference setting on your ROAM?

How to set wheel circumference for a Speed or Speed/Cadence Sensor in the Wahoo or ELEMNT App – Wahoo Fitness Support

1 Like

Hi jGreengrass thanks for replying.
I always had that to do with the old magnetic sensor, but i cannot find a way to do that either on the roam or the elemnt app.