Wahoo X May Challenge - Pursuit of Pink!

Sir Glen, I understand your point. I use RGT, but I could not ever endorse it, at this time. Hopefully someday. By contrast, all of Sufferfest and most of Systm is great. Not perfect, but as good as there is out there and far better than most.

For me, and please understand I am speaking just for me, RGT is a miss on too many levels. With each ‘upgrade’ the experience seems to worsen. Again, again, again, for me. I am very happy that others find it useful, and even love it.

It’s nice to have in the offering, but if it wasn’t there, I for one would not miss it. If it becomes a mandatory part of whatever in the hell they call the event formerly known as ToS or the monthly challenge, I would be out. I know nobody cares, but I wouldn’t either.

But I must ask, why have you missed most of them???


I’m not saying I’d miss it. But I am GLAD it’s there. I am very aware of the, umm, challenges, you’ve had with it Sir Stuart and I am also aware of the support that’s been offered, albeit, in your case with somewhat limited success. I hope beyond hope that it doesn’t form a mandatory part of then event formerly known as the ToS. I also hope they go back to calling it the ToS. There are ways they can do that while at the same time encouraging folks to explore other parts of The Company’s offerings. At the very least, I hope they don’t EVER call it The Tour whose name I can’t even bring myself to say.

To be perfectly honest, the monthly challenges just haven’t appealed to me. That said, the possibility of winning some ACTUAL swag is pretty tempting and May isn’t over yet so I may still go for the EF Pienza Challenge on RGT. I have some other, erm, reasons (*cough, excuses) but let’s just say I need to spend a little more time at flogging station #159.


This came up a few weeks ago and I mentioned at the time that I didn’t even know they were doing that. I just felt it was easy enough to fold in to my planned rides. It does have to get pushed around sometimes as my bigger goal to complete all the past ToS will always take precedent.

On that topic, I know I can count on you joining us for ToS 2016 coming up in a few weeks! Please consider this your formal invitation, kind Sir.


Thanks for the invite Sir! I’ve been following your retro tours and it’s been most enterpaining. 2016 was my first. Such fond memories. You’ll have a great time, except for the times you’ll be asking yourself whose idea it was to do this :wink:


Some crazy Rat Bastard from California I think. :thinking:


Can you please explain this. On the SYSTM app I have set the workout to outside and it has appeared on the Bolt ready to ride but what next? I need to take a phone or something?


That’s NEXT month’s goal, @AdamC. Have to walk before you can run…


1 Like

You need to run the app workout to get the badge… an outdoor workout will not count on its own. You simply play it so that you can get “credit” and earn the badge… you could just do this at your desk later if you wanted… honor system and all

1 Like

Thank you. So I don’t need to pair sensors or ride along with more voices than normal.


@Rupert.H Wow - that is impressive! I really enjoy that Pienza loop - those climbs are definitely spicy! Also I liked seeing how well the pros races the course versus the rest of the leaderboard.

1 Like

@AdamC Currently the way the badge is programmed within the software only indoor rides are recognized. The workaround is to dual record - doing the workout on your bike computer and also running the workout in the SYSTM player. You will end up having two workouts on you calendar.

1 Like

Haha. LOVE this!

Sure, outdoor workouts are not recognised so if you want it to count you can play the workout while you ride and then save it to count towards the challenge

1 Like

I’ve tried, I really have. But this is not the sort of suffering I expected when I innocently clicked on the monthly challenge.

How do I start the ride? I’ve logged in to RGT (first the website then the app), added my equipment , set my detailed. I’ve found the monthly challenge ride in various lists. In one UI, there was a ‘Ride Now’ banner, which took me to a ride description page. from the RGT home page, there was a ‘View’ button, which took me to the same place. Now I see a Sign Up button, which yields no discernible response.

I know it’s something I’m doing, or not doing, but I have no idea what.


Hi @MFord - I initially found it a bit confusing with how to get started with this. As was also keen to ride the challenge thing. One of the things I’ve noted is the app in Windows (Windows 10 in my case) isn’t ‘quick’.

For example - to get the actual ride started is a bit of an odd experience. So this may be happening to you as well.

When I start RGT, I wait until the Home Screen appear with the option for Events.
I go in to Events, scan around and and I select EF Pienza

When that is selected there no option to actually start a ride to begin with - which made me think there was something I hadn’t done. Then once, I just gave up on it and did something else with the PC, and looked back …. voila a Ride Now button had appeared. So it’s like something happens in the background to allow you to start. So I now just wait after any ride I select and see if a button comes up further down the screen

Not sure if that helps or if it is a step earlier maybe, but just in case


Oh - and you have to ride two laps … nothing I saw on screen said thst while I was riding but I luckily didn’t notice I was past one lap then a memory triggered of someone posting that to finish it you need to keep going and get to the top twice (I know somewhere it will say all this, I just hadn’t spotted it)


@Martin @MFord Correct - once you sign up and go into the event the ride has to load on the server. Scroll down to the Join an Event topic in the link below to get an overview.


Like @martin notes RGT is not immediately intuitive at 1st so it take a bit of getting used to it. @MFord I would suggest setting aside some time to explore it and take some notes on setup and read through the tutorial. I was initially confused as well but have grown to appreciate the versatility of the platform.


So I did the Pienza ride tonight… but only after enduring a LOT of FRUSTRATION. I did another ride first, just to make sure things were working and to figure out how to use the steering on my KICKR Bike. It was nothing but a hassle. I’ve ridden 3 or 4 rides on RGT, the last being probably last summer. Steering was not a factor then, all automated, as far as I recall. But connecting my KICKR Bike was a total fiasco tonight.
First, an App update was required, expected that and complied. It wasn’t what I’d call smooth or professional. I downloaded and saved the install file, ran it, nothing said whether I should close the old app upon completion or not, but the app “reopened” as far as I could tell, and I tried to proceed. Eventually wasn’t sure if I was still in the old app or actually in the newly installed version. It was asking me to Log In or Add account, or whatever. That looked like it would be the new app. But something wasn’t looking right to me, can’t remember what, so I totally closed out the program again. Then looked on my desktop where there HAD been an RGT shortcut to start it up but now that shortcut was a folder, and Properties showed it to be an (MSIX?) file, which is an install file, not the EXE file to run RGT. So I went back into the Windows/ProgramFiles folder and found the Wahoo/RGT folder and then ran the WahooRGT.exe file again to open the app/program again and start fresh. (and later created a shortcut to that one, deleted the OLD folder that was on the desktop, and replaced with the newly created shortcut. Those steps need to be properly done by the UPDATE to RGT file when we install it, or at least the option to do so should be presented to us during installation; they should not be something we have to do on our own, IMO.)

RGT opened fine, showed me the Log In or Add account options, and I logged in with my account. I used the MENU and poked around a bit to refresh on what things were, and went to My Account, and used the IMPORT SYSTM 4DP settings option that was shown. That went fine, immediately had my current settings from SYSTEM. I edited my weight for the couple pounds I’ve dropped since the last time I updated in SYSTM (and did the same in the SYSTM app.)

I also used the MENU/EQUIPMENT to change my Avatar (kit, bike, helmet, sunglasses.) Easy enough.

Finally ready to get in a ride, or so I thought. I went to the first ride option showing on the Home Page, the Dunoon Seafront Circuit, alongside the Pienza Challenge ride that I was mainly wanting to do but I needed a warmup first.

So I hit the RIDE NOW button for Dunoon and it loads up, there is my avatar on the road, I’m already pedaling all this time as I’ve worked through these steps… My avatar is just sitting there not moving. I think I had already gone to MENU/SENSORS earlier, when I poked through the MENU options, and had my ANT+ dongle connected to the PC and switched on the buttons for the KICKR Bike and all its sensors. If not, I did that at this time, seeing the avatar sitting there and nothing happening, though the fans were making noise, etc.
I will add my agreement to another comment I’ve read on here about the White buttons being confusing. They LOOK like they are ON with that white button. When I clicked them to check, I then saw that they turn GREEN and move to the right to indicate what is REALLY ON. That is just not intuitive. Can we figure it out eventually? Yes. But really, a grayed out button is FAR more intuitive and easy to recognize quickly. Then you could use WHITE OR GREEN to indicate ON and it would still be readily recognizable for what it is.

In any case, I had various green buttons showing that my KICKR Bike sensors were turned ON and should have been moving my avatar around the course, but it just wasn’t moving at all. I pedaled harder, softer, shifter gears, nothing made any difference.

I finally just closed out the program altogether again. I opened RGT again, I think it then had my user in there to select as Rider, and opened to the Home Page. I checked Sensors again, made sure my ANT+ was turned ON and the KICKR Bike sensors were active and it was connected. (I THINK but am not certain that it previously had been saying CONNECTING but possibly not CONNECTED to the KICKR Bike?)
So I started the Dunoon ride again, this time my avatar was moving as soon as it loaded up and my power and other data started showing up. FINALLY! So I started figuring out how to ride RGT again.

The steering factor was something I dreaded more than I should have. It was okay, definitely NOT as intuitive as I think it should be, because it wobbles so much when you have to cut across several lanes; takes multiple bumps on the button, and the rider sort of wobbles a bit over and over to get there but wants to return back against the turn if you don’t hold keep the right timing of each button bump, OR you can hold the button down and keep crossing lanes, but that too is hard to really control smoothly because it wants to oversteer too far instead of drifting across in a manner that is more like taking a straighter line toward the inside of a corner ahead of you.)

I don’t give the steering a fail, but it just isn’t a big deal to me, probably because I won’t be doing much RGT at all unless it becomes a LOT more intuitive in many ways. But the drafting benefit that shows when you get up behind someone and use the draft is at least a “feature” and can add interest for those who use RGT. And I have to say that the steering buttons on the KICKR Bike are easy to use, certainly much more convenient compared to some comments I’ve read of others having to use the phone to change lanes, etc.

After getting some experience using the steering buttons, I started realizing that it was MY responsibility to shift gears if I wanted to make any time. I remember seeing a USE ERG mode button somewhere along the line to this point but hadn’t connected mentally to the fact that the WHITE button meant I was NOT in ERG mode. In SYSTM, I’m so used to ERG most of the time that I have to get used to shifting much more intentionally to achieve speed and power numbers. I started getting that into my thinking but it will take a lot more experience with that to reap benefits.

After doing the Dunoon ride, I came by the starting line, realized I’d done over 5 miles and needed no more for a warmup, since I had worked harder than a warmup ride as I played with some drafting and surges a little, so I figured out to hit the Menu/End Ride and clicked on out, once again not noticing the WHITE BUTTON below was NOT an ON or SELECTED button, so my ride did NOT save to Strava. :confounded:

PIENZA May Challenge ride was my main goal, so I did that next. It was NOT INTUITIVE. I wasted so much time trying to figure out HOW in the HECK TO GET TO THE RIDE!!
Like others have said, but I had not realized or remembered, the RIDE NOW option is VERY SLOW to show up. I must have used the Pienza VIEW button 3, 4, maybe 5 times and then read through and scrolled down, back up, down, up, searching for a way to DO THE RIDE! It just wasn’t there!
I was getting SO frustrated. I’d looked out on the web at RGT help, trying to find anything that would steer me in the right direction.

FINALLY, I went back to the RGT app that was still open and THERE IT WAS, the RIDE NOW (or LEAVE) button(s) at the bottom of the left side of the page.
I started the ride and did the 2 laps, giving the 2 segments just a moderately good effort the first time around, and then had to just spin for several minutes on the 2nd lap just to complete the ride. (During the ride, I had to Alt-Tab to a browser window to lock in some autumn vacation lodging for a trip to climb Mt. Katahdin in Maine this fall, as soon as I heard back from the lodging host. I couldn’t let ANYTHING screw up these dates this year! We had to bail and miss the trip completely last year when I came down with pleurisy topped with pneumonia just before we were to leave.)
Once I completed the Pienza 2nd lap, I used the Menu END RIDE option. It closed out, I then CAUGHT the option to upload to Linked accounts and switched it ON (GREEN!) before exiting.
One REAL GRIPE HERE: there is NO OPTION TO LINK TO GARMIN?? SERIOUSLY?? That’s pathetic, IMO. So I had to go back out to the MENU/ACCOUNT/RIDE HISTORY section, and choose my earlier Dunoon ride and Click the GET RIDE DATA button, then choose STRAVA to upload it to Strava. That worked. Then I had to repeat the GET RIDE DATA and choose EMAIL, which sent an email with a FIT file and a GPX file to me, which I then had to SAVE to my computer, then go into Garmin Connect and UPLOAD and browse to that saved file. And I had to REPEAT those steps for the PIENZA ride to get it to my Garmin Connect account. And I could look forward to that hassle with EVERY RIDE I do in RGT?? That’s just seriously unacceptable and yet another incentive NOT to use RGT.

I did play a little bit with coasting during this Pienza ride, and while I can’t say this with great conviction because it was just a little bit of time, I do FEEL that maybe RGT does a more realistic job of letting coasting speeds on downhills act closer to what the bike does in real outdoor riding than SYSTM does or what the KICKR Bike does when controlled by a Garmin Edge following an outdoor course, for example. When I coasted downhill, I didn’t feel such immediate loss of speed as I often do as soon as I let off the pedals in what I think are similar situations in SYSTM or with the Garmin controlling. And I THINK I actually saw my speed increase just a bit more after letting off the pedals on a downhill in the Pienza ride. I don’t think I EVER see that anywhere else, even though I’ve ridden outdoor courses on the KICKR Bike that absolutely SHOULD HAVE done that, but instead, they dragged my down too quickly. That has caused me to habitually overwork on downhills just trying not to lose too much off my average speed.)

SO, BOTTOM LINE? I’m not meaning to slam RGT but the FRUSTRATING ASPECTS of just USING THE APP are far too AGGRAVATING for me to think I want to subject myself to that just to get my indoor ride done. No way. IT MUST be more intuitive, faster responding, (i.e. the RIDE NOW button just CANNOT take so long to show up that we give up and go back to something else trying to FIND IT!)
And when a user has LOADED A RIDE that they’ve selected, and the avatar does not even start moving, could there please be SOME NOTIFICATION that tells them SOMETHING? Like NO SENSOR CONNECTED? Something? Obviously, the user THINKS the sensor IS connected or they would have backed out and started again.

Finally, restart on top of restart should NOT be a normal thing to endure for any user, and surely that experience isn’t going to bring that user back to RGT very many times. In a lot of cases, once they’re done, they’re DONE.


So you didn’t like it, then?



Sorry, couldn’t help myself. And I’m sorry you and so many others seem to have so much difficulty with RGT that it has put you off.